ShopApiPlugin with Sylius 1.9

I’m trying Sylius for the first time and will need to use the Shop API. I have installed Sylius 1.9 easily enough but am having trouble installing ShopApiPlugin.

Composer tells me that it can’t resolve a set of packages:

Problem 1
- Conclusion: don't install symfony/messenger v5.2.0
- Conclusion: don't install sylius/shop-api-plugin v1.3.1|install symfony/messenger v5.2.0
- Installation request for symfony/messenger (locked at v5.3.2) -> satisfiable by symfony/messenger[v5.3.2].
- Conclusion: remove symfony/http-kernel v5.3.2
- Installation request for sylius/shop-api-plugin ^1.3 -> satisfiable by sylius/shop-api-plugin[v1.3.0, v1.3.1].
- Conclusion: don't install symfony/http-kernel v5.3.2
- sylius/shop-api-plugin v1.3.0 requires symfony/messenger ^4.4|5.2 -> satisfiable by symfony/messenger[v4.4.0, v4.4.1, v4.4.10, v4.4.11, v4.4.12, v4.4.13, v4.4.14, v4.4.15, v4.4.16, v4.4.17, v4.4.18, v4.4.19, v4.4.2, v4.4.20, v4.4.21, v4.4.22, v4.4.25, v4.4.3, v4.4.4, v4.4.5, v4.4.6, v4.4.7, v4.4.8, v4.4.9, v5.2.0].
- symfony/messenger v4.4.0 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.1 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.10 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.11 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.12 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.13 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.14 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.15 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.16 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.17 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.18 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.19 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.2 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.20 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.21 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.22 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.25 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.3 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.4 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.5 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.6 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.7 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.8 conflicts with symfony/http-kernel[v5.3.2].
- symfony/messenger v4.4.9 conflicts with symfony/http-kernel[v5.3.2].
- Installation request for symfony/http-kernel (locked at v5.3.2) -> satisfiable by symfony/http-kernel[v5.3.2].

To me this says that shop-api-plugin isn’t compatible with Sylius 1.9. Is this true? If not, how can set up a Sylius 1.8 installation? I can’t find any documentation about installing specific version. I tried composer create-project sylius/sylius-standard sylius ^1.8 but that just installed 1.9.

Debugged it with help on Slack. ShopApiPlugin’s symfony/messenger requirement should be ^5.2 but is 5.2. Will submit a PR.