Metadata storage is not up to date

Hi,
I’ve been trying to install sylius. Everthing works fine until I type the command :

bin/console sylius:install

Here is the output:

Step 1 of 4. Checking system requirements.

Success! Your system can run Sylius properly.

Step 2 of 4. Setting up the database.

Creating Sylius database for environment dev.
It appears that your database already exists.
Warning! This action will erase your database.
Would you like to reset it? (y/N) y
0/4 [░ ] 0%
In MetadataStorageError.php line 13:

The metadata storage is not up to date, please run the sync-metadata-storag
e command to fix this issue.

I tried:

php bin/console doctrine:migrations:sync-metadata-storage

but I get the same output.

From php forums, I read that this error could be fixed by adding the maria version to the database_url in the .env file.
Opening mariadb, I have:

Server version: 10.3.25-MariaDB-0+deb10u1 Debian 10

So, in the .env file, I tried to change, with no succes, the line:

DATABASE_URL=mysql://root@127.0.0.1/sylius_%kernel.environment%

to:

DATABASE_URL=mysql://root@127.0.0.1/sylius_%kernel.environment%?serverVersion=mariadb-10.3.25

What line could I try to make it work ?
Do you have other ideas ?

Hi There…

this Issue comes with the use of mariaDB instead of Mysql …

You have to do the following steps:

in the .env file … edit this line:

DATABASE_URL=mysql://db-username:db-password@127.0.0.1/db-name

So in this example

Username for MySQL: db-username
Password for this User: db-password
Name of Database for shop: db-name

after that you have to get your mariaDB version… i used phpmyadmin for that

Output should be sth like
Server-Version: 10.3.23-MariaDB-0+deb10u1 - Debian 10

Next step is to edit the file config/packages/doctrine.yaml

mine looks the following now:

image

after that, the install went smooth…

Hope this helps,

Cheers,
Chris