Installing default Sylius on Ubunutu 20.04 (Digital Ocean)

Hi all,

I am having some trouble installing the default Sylius on my server. I took the following steps, lines starting with # denote changes/actions made in config files.

sudo add-apt-repository ppa:ondrej/php
sudo apt update
sudo apt install nodejs
sudo apt install apache2
sudo systemctl stop apache2.service
sudo systemctl start apache2.service
sudo systemctl enable apache2.service
sudo apt-get install software-properties-common
sudo apt install php7.4 libapache2-mod-php7.4 php7.4-common php7.4-sqlite3 php7.4-mysql php7.4-gmp php7.4-curl php7.4-intl php7.4-mbstring php7.4-xmlrpc php7.4-soap php7.4-ldap php7.4-gd php7.4-bcmath php7.4-xml php7.4-cli php7.4-zip
sudo vim /etc/php/7.4/apache2/php.ini
#memory_limit = 256M
#upload_max_filesize = 100M
#max_execution_time = 360
#date.timezone = Europe/London
sudo vim /etc/php/7.4/cli/php.ini
#date.timezone = Europe/London
curl -sS https://getcomposer.org/installer | sudo php -- --install-dir=/usr/local/bin --filename=composer
curl --compressed -o- -L https://yarnpkg.com/install.sh | bash
sudo apt-get install mariadb-server mariadb-client
sudo systemctl stop mariadb.service
sudo systemctl start mariadb.service
sudo mysql_secure_installation
# Set up DB, create base user + DB, grant user privileges on DB, flush privileges, exit.
sudo systemctl restart mariadb.service
cd /var/www
composer create-project sylius/sylius
cd sylius
yarn install
yarn build

At this point in the procedure, I get an error:

[16:27:46] Error in plugin 'gulp-chug'
Message:
    Gulpfile /var/www/sylius/src/Sylius/Bundle/ShopBundle/gulpfile.babel.js exited with an error :(
Details:
    domainEmitter: [object Object]
    domain: [object Object]
    domainThrown: false
[16:27:46] 'build' errored after 34 s
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

Please note I have tried the following work arounds:

  1. Removing node_modules and running install & build again with NPM instead of Yarn
  2. npm cache clean --force => delete node_modules folder => delete package-lock.json file => npm install
  3. I have also tried changing my NodeJS versions, versions <10.x don’t work due to dependencies and those >= 10.x fail in the same manner.

Any help would be greatly appreciated!