Configure password encoder

Hello,

I am trying to deploy a Sylius application Google App Engine’s Flex environment, but I keep receving an error because the PHP 7.2 image does not have support for Argon2i.

How can I configure Sylius to not use ‘argon2i’ as encoder and instead use ‘auto’?

I have tried editing the security.yaml file, but with no luck:

security:
    encoders:
        Sylius\Component\User\Model\UserInterface: auto

Try this

security:
    encoders:
        auto: auto
        Sylius\Component\User\Model\UserInterface: auto

Or this in the sylius_user configuration

sylius_user:
    encoder: auto
    resources:
        admin:
            user:
                encoder: auto
                classes:
                    model: Sylius\Component\Core\Model\AdminUser
                    interface: Sylius\Component\Core\Model\AdminUserInterface
                    repository: Sylius\Bundle\UserBundle\Doctrine\ORM\UserRepository
                    form: Sylius\Bundle\CoreBundle\Form\Type\User\AdminUserType

I had a similar problem, I do not remember how to solve it, if with the first option or the second, although I think it was using the 2 together.

Thanks for your answer.

I solved it by setting this in security.yaml:

    encoders:
        argon2i: auto
        Sylius\Component\User\Model\UserInterface: auto