Composer : cache:clear exceeded the timeout of 300 seconds

Hello,
I am trying to create a new install of sylius with the symfony 4 structure.
I use the command composer create-project sylius/sylius-standard with php 7.2.10
At the end I’ve got this error :

Executing script cache:clear

[Symfony\Component\Process\Exception\ProcessTimedOutException]
The process "“C:\wamp64\bin\php\php7.2.10\php.exe” “–php-ini=C:\wamp64\bin\php\php7.2.10\php.ini
" “bin/console” --ansi cache:clear” exceeded the timeout of 300 seconds.

What is strange is that I’ve got another sylius project with the old structure and the cache clearing works.
I tried the command php bin/console cache:clear and I’ve got the same problem.

Any idea ?

Thank you !

I have also the same error !

What’s the value of max_execution_time?
Do you have debuger enabled?
Maybe try to run composer create-project with the --no-scripts flag and run php bin/console cache:clear separately after that.

Me to. Xdebug Off.

1 Like

Hi,

Any solution to fix this issue because I am facing the same problem ?

Hope you do have a solution because I just can’t create a new Sylius project for now.

Increase the timeout: https://getcomposer.org/doc/03-cli.md#composer-process-timeout