Can`t extend ShopBillingData model

Hello,
I need to add phone number field to shop billing data form in order to do that I need to customize ShopBillingData entity and ShopBillingDataType. I already wrote a ShopBillingDataType extension and it seems that it is working but I cannot extend ShopBillingData model. I did everything according to documentation

I created ShopBillingData model in in my_project/src/entity/ShopBillingData.php:

<?php

declare(strict_types=1);

namespace App\Entity;

use Doctrine\ORM\Mapping as ORM;
use Sylius\Component\Core\Model\ShopBillingData as BaseShopBillingData;
use Sylius\Component\Core\Model\ShopBillingDataInterface;

/**
 * @ORM\Entity
 * @ORM\Table(name="sylius_shop_billing_data")
 */
class ShopBillingData extends BaseShopBillingData implements ShopBillingDataInterface
{
    /** @ORM\Column(type="string", nullable=true) */
    private $phoneNumber;

    public function getPhoneNumber(): ?string
    {
        return $this->phone_number;
    }

    public function setPhoneNumber(string $phoneNumber): void
    {
        $this->phone_number = $phoneNumber;
    }
}

and I added such configuration in my_project/config/packages/_sylius.yaml file:

sylius_core:
    resources:
        shop_billing_data:
            classes:
                model: App\Entity\ShopBillingData

As I understand when I run php bin/console debug:container --parameter=sylius.model.shop_billing_data.class command I should see that my new model is used but it shows that still old model is used. So what I am doing wrong?

What version of Sylius do you have?
It wasn’t possible to extend this entity prior to 1.7.0
See https://github.com/Sylius/Sylius/pull/11108

I have 1.7.0 version installed

Looks like the issue wasn’t fully fixed, the parameter is explicitly set in https://github.com/Sylius/Sylius/blob/master/src/Sylius/Bundle/CoreBundle/Resources/config/services/form.xml#L54
Add to config/packages/_sylius.yaml

parameters:
    sylius.model.shop_billing_data.class: App\Entity\ShopBillingData

It worked. Thank you!